Unmet dependencies

After wasted two days on installation of libraries files for opencv I am getting a little bit off help from my elder brother Harman. He is explaining about the versions of libraries files and they also tells that I am not following the latest installation documentation of opencv.

I am trying to install libgtk2.0-dev as mentioned in installation documentation of opencv and error occurred  as

The following packages have unmet dependencies:
  libgtk2.0-dev : Depends: libpango1.0-dev (>= 1.20) but it is not going to be installed
  Depends: libcairo2-dev (>= 1.6.4-6.1) but it is not going to be installed
  E: Unable to correct problems, you have held broken packages.

But when I trying the latest version of libgtk-3-0 all dependencies is solved and it is installed in my laptop.

The below following links which is used in installation of libraries files are given below :



FollowFollow on FacebookFollow on Google+Email this to someone

Leave a Reply

Your email address will not be published. Required fields are marked *